Feature request #4006

Filter (on load) Postgis layers by canvas Bounding Box

Added by Giovanni Manghi over 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Vectors
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No

Description

If a user don't want to load all the features of a Postgis layer can build a filter with the query builder. It would e nice also to have the option to limit the features to be downloaded using the canvas Bounding Box, as in the WFS client.

Actually a user must build a query as (example)

the_geom && ST_SetSRID(ST_MakeBox2D(ST_Point(14,43),ST_Point(16,46)),4326)

that is not very handy


Related issues

Duplicates QGIS Application - Feature request #3227: Load PostGIS layer only for current canvas extent Open

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Target version set to Version 1.7.4

#2 Updated by Giovanni Manghi almost 6 years ago

  • Pull Request or Patch supplied set to No
  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #3227

Also available in: Atom PDF