Bug report #3848

print composer: Image remove from Item tab doesn't work

Added by Donkagen2 - over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:13906

Description

When working with images, on the Item tab the Remove button doesn't work as expected.

If an image is selected in the Preview window and Remove is clicked, the selected image remains but a group of images at the start of the list are removed.

History

#1 Updated by Marco Hugentobler over 9 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

The 'remove' button is in the 'directory' group box -> it means that an image search directory is removed, not an individual image.

#2 Updated by Donkagen2 - over 9 years ago

Ok, but it isn't intuitive.

To add images one clicks Add... , a dialog opens and then select the directory to add. The dropdown list of directories isn't used.

To remove images (or in this case their directory) the user has to guess the directory from the drop-down list before clicking Remove. If they guessed correctly, the images are removed but if not then they've lost the wrong images and details about the directory that they were in. All this time, the user is presented with a highlighted image, giving the impression that it is what will be removed.

Expecting a user to guess what will be removed, still seems to be a bug.

A more intuitive way could be to open a dialog when Remove is clicked and present a pick list there. Picking would highlight or otherwise identify the images in the selected directory, then clicking OK would remove the images that the user intended - no scope for confusion.

Also available in: Atom PDF