Bug report #3825

Two decimal places for symbology in map unit is not suited for lat-long data

Added by Mayeul Kauffmann over 9 years ago. Updated about 9 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Vectors
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:13883

Description

In new symbology, when selecting size, width, offsets etc. in "map unit", the minimum value is either 0.00 or 0.01, because only 2 decimal places are allowed.
At 45° North latitude, 0.01 degree=786 meters, which renders symbology based on map unit useless on lat-long data at most scales.
It is impossible to chose for instance "0.0001" (about 8 meters) to represent a small road or a track.
The resolution should be at least 5 decimal places to support a minimum of "0.00001" (80cm), which makes sense for "street maps" (e.g. with "Open Street-Maps" data in lat-long): sometimes you find a path in very narrow streets, with buildings less than two meters away from each other.

History

#1 Updated by Anita Graser about 9 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed

duplicate of #4217

#2 Updated by Anita Graser about 9 years ago

  • Resolution set to duplicate

Also available in: Atom PDF