Bug report #3823

qgis_mapserv.fcgi segmentation fault

Added by Niccolo Rigacci over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:QGIS Server
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:
Crashes QGIS or corrupts data: Copied to github as #:13881

Description

I have QGIS compiled from GIT, version 9ffedb4 on an amd64 machine.

I'm trying qgis_mapserv with a simple project, but it crashes with segmentation fault or with this message:

qgis_mapserv.fcgi: checksum.c:150: crc32: Assertion @length >= 0' failed.
Aborted

The problem exists also if I call the cgi-bin from the command line, like this (the QUERY_STRING must be on a single line):

cd /usr/lib/cgi-bin/toscana
QUERY_STRING="SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap
&BBOX=9.66321,42.2097,12.4125,44.4741&SRS=EPSG:4326&WIDTH=320
&HEIGHT=200&LAYERS=province&FORMAT=image/png" ./qgis_mapserv.fcgi > pippo.png

The very same project gets rendered OK in QGIS 1.6.0.

Can someone confirm that there is a bug?

Here you can find the project with the shapefile: [http://argo.rigacci.org/toscana.tar.bz2]

History

#1 Updated by Marco Hugentobler over 9 years ago

The layer renders ok for me with latest git version of QGIS server. I however loaded / saved the project with 1.7 because of the file path.
Could you test if a fresh project with the layer works? Also, make sure the server uses the right QGIS libraries (sometimes there are problems if there are several versions and it uses the wrong one).

#2 Updated by Marco Hugentobler over 9 years ago

  • Status changed from Open to Closed

Closing the ticket as no further feedback. Please reopen if it is still a problem

Also available in: Atom PDF