Feature request #3785

ComboBox switches back to another position after New or Update in 'Open DataSource...' dialogs

Added by Sfkeller - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Pull Request or Patch supplied: Resolution:duplicate
Easy fix?:No Copied to github as #:13843

Description

After adding a new data source, like Spatialite or WMS (or after editing), the ComboBox in the modal "Add..." dialog switches back to 1st or old item. But user expect that the ComboBox shows the recently added (or edited) item.

Example: In order to add a new WMS one has to open the "Add WMS Layer..." dialog. At this time say "WMS ZZZ" is shown in the ComboBox. Then one clicks "New" to add a new entry, for example "WMS AAA". After closing (click on "Ok"), the ComboBox still shows "WMS ZZZ". But one would expect that now "WMS AAA" is shown, since that is the newly added item. Same applies when editing an item.

History

#1 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #3614

Also available in: Atom PDF