Bug report #371

Raster drawing errors

Added by jeremy_fergason-yahoo-com - about 14 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:RedHat Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:10430

Description

When loading very large rasters the image does not always get drawn correctly. Sometimes the left most portion of the image gets drawn twice or more to cover the right most part of the image.

This appears to be true for several different raster formats (I tested Mr. Sid and Geotiff). You can reproduce this result by creating an image that is 10000 pixels wide and 5000 pixels high and fill it with a simple gradient (green to red is what I used) and save as a tif. Then load up and and zoom in on a thin strip covering the full width but only a portion of the height.

History

#1 Updated by Gavin Macaulay - about 14 years ago

What version of gdal is qgis using? (available in the Help:About dialog box under the Providers tab). In our experience, most raster problems are due to the raster reading library that qgis uses.

#2 Updated by Gavin Macaulay - almost 14 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

No feedback for a month, and works for me with qgis 0.8 RC1 and gdal 1.3.2.

#3 Updated by Anonymous over 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF