Feature request #3704

Shapefile: please improve column management

Added by Stemby - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Documentation and Help
Pull Request or Patch supplied: Resolution:invalid
Easy fix?:No Copied to github as #:13763

Description

From the manual, section 3.4.7. "Attributes Tab":

"At the moment only columns from PostGIS layers can be removed and added."

That's a very big obstacle for students and simple users. Please, please concentrate your efforts to close that issue.

Thank you very much for your beautiful software.

Regards,
Carlo

History

#1 Updated by Giovanni Manghi over 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Shapefiles columns can be added without any obstacle in many ways: trough the attributes table itself, trough the vector properties, trough the field calculator, etc.

Columns cannot be removed but this IS a OGR limitation: in the gdal/ogr trac you'll find a ticket and a patch that awaits to be committed. Until then QGIS (and any other software that uses gdal/ogr) can only use a workaround to delete shapefile columns. In QGIS this "workaround" is a plugin called TABLE MANAGER.

#2 Updated by Jürgen Fischer over 10 years ago

duplicate of #1446

#3 Updated by Stemby - over 10 years ago

Ok, thank you.

I think your clear explication would be useful if inserted in the manual.

Regards,
Carlo

#4 Updated by Giovanni Manghi over 10 years ago

Replying to [comment:3 Stemby]:

Ok, thank you.

I think your clear explication would be useful if inserted in the manual.

Regards,
Carlo

You are right: you can see that this trac also has a category for "documentation", so feel free to propose a patch for the manual with a paragraph explaining better this issue.

Also available in: Atom PDF