Bug report #3694

WMS quality worse on QGIS server compared to QGIS desktop

Added by Andreas Neumann over 9 years ago. Updated about 9 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:13753

Description

Since a couple days/weeks it seems like the display quality of WMS, when used through QGIS server got substantially worse.

It could be either a dpi, or a resampling issue, or an unnecessary reprojection which results in lower quality.

Here is a test URL:
Original UMN Mapserver URL with original quality:
http://gis.uster.ch/cgi/mapserv?map=/home/www/mapserverdata/uster_uep.map
WMS through QGIS server:
http://gis.uster.ch/cgi/qgis_mapserv.fcgi?map=/home/www/projekte/orthofotos_und_uep/orthofotos_und_uep.qgs
Layer: Übersichtsplan 2009

History

#1 Updated by Andreas Neumann over 9 years ago

Here is a Screenshot: on the left is the better quality of QGIS desktop, on the right the lower quality of QGIS server. Both use the same WMS from UMN mapserver as a source.

http://gis.uster.ch/bugreports/qgis/qgis_desktop_vs_server.png

#2 Updated by Redmine Admin over 9 years ago

The DPI bug was fixed in trunk 72ee7e6d (SVN r15700). Can you verify if this ticket was also fixed?

#3 Updated by Jürgen Fischer about 9 years ago

  • Assignee deleted (Redmine Admin)
  • Category changed from Rasters to Web Services clients/WMS
  • Status changed from Open to Feedback
  • Pull Request or Patch supplied set to No

#4 Updated by Andreas Neumann about 9 years ago

  • Resolution set to worksforme

I think this was fixed meanwhile. I don't see the problem anymore.

Andreas

#5 Updated by Giovanni Manghi about 9 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF