Bug report #3682

Delimited Text Layer Plugin and empty columns

Added by zirneklitis - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13741

Description

Delimited Text Layer plug-in does not cope with TAB delimited text with extra TAB mark at the end of each row. Such a file is parsed, and a layer is added, but no geometry can be found in the map.

extra_tab_symbol.csv.zip - A TAB separated text file with extra TAB mark at the end of each row (1.42 KB) zirneklitis -, 2011-03-27 03:52 AM

extra_tab_symbol_37c.csv.zip - With line #37 corrected (1.42 KB) zirneklitis -, 2011-03-27 04:33 AM

Associated revisions

Revision e169c28a
Added by Jürgen Fischer over 10 years ago

fix #3682

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision e2de267b
Added by Jürgen Fischer over 10 years ago

fix #3682

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Volker Fröhlich over 10 years ago

That's not a problem of tabs at the end of lines, it doesn't seem to work with tabs at all. Substituting all tabs with pipes works for me.

What I find more problematic, is line 37 "Madona", which has one additional field.

#2 Updated by zirneklitis - over 10 years ago

Let's skip or correct this line 37. I have added the new version of the problematic file.

The problem is not in TAB as a delimiter, but with an extra TAB at the end of lines. Just remove these extra TAB symbols and the file is readable for QGIS.

In short: Delimited Text Layer plug-in is not capable to read TAB delimited text files with extra TAB symbols at the end of lines.

It's quite easy to generate such incorrectly formatted text files. Delimited Text Layer plug-in must be more forgiven for such mistakes.

#3 Updated by Volker Fröhlich over 10 years ago

I should have said I'm trying on Trunk. Removing the trailing tabs does not help on Trunk. Just replacing them with pipes, for instance, solves the problem, even if they are trailing.

Something about trailing delimiters was corrected after 1.6, if I remember correctly, but I can't find it now.

gsherman might be the better addressee, by the way.

#4 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

the problem were the quoted column names. Fixed in e2de267b (SVN r15615).

Also available in: Atom PDF