Bug report #3660

Identify Feature not working with WMS layer

Added by mbagni - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:13719

Description

Hi,
I have encountered the following error which occurs only with the Linux version 1.6.0 (under Windows version 1.5.0 it works fine):

having selected and displaye a WMS layer the function to Identify a feature does not work (returns always an empty dataset).

QG_About.jpg (44.6 KB) mbagni -, 2011-03-22 12:44 AM

Feature_Info.jpg (16.8 KB) mbagni -, 2011-03-22 12:44 AM

History

#1 Updated by Giovanni Manghi over 10 years ago

can you tell what server and layer?

#2 Updated by mbagni - over 10 years ago

Replying to [comment:1 lutra]:

can you tell what server and layer?

Different servers (I was testing mine) but for sure this is a server used
in OpenLayers demo (Openlayers-2.10/examples/getfeatureinfo-control.html)
WMS Server:
http://demo.opengeo.org/geoserver/wms

Layer:
topp:tasmania_water_bodies

I have checked with my MapServer installation and the Linux version sends
a correct URL (only asks for text/plain instead of text/html as the
Windows version 1.5.0 does) and MapServer replies with a string that is
not inserted in the Feature attributes box.

Cheers

#3 Updated by Jürgen Fischer over 10 years ago

Replying to [comment:2 mbagni]:

WMS Server: http://demo.opengeo.org/geoserver/wms
Layer: topp:tasmania_water_bodies

Works for me in Trunk - I get a html response.

#4 Updated by mbagni - over 10 years ago

You get the correct response but I don't.
For your info I am running QGIS under KNOPPIX 6.2.1
I have attached two screenshots, one of the About and the other of the Feature window AFTER having clicked on a water body of the layer I gave you.
WHen you say "Trunk" are you referring to the same version under the same operative system (at least Linux Debian)?
Anyway, if you have checked under Linux Debian and it works for you I am releaved. Maybe it is and idiosyncracy of KNOPPIX.

Anyway Thanks!

#5 Updated by Giovanni Manghi over 10 years ago

WHen you say "Trunk" are you referring to the same version under the same operative system (at least Linux Debian)?

it refers to the svn/development version, If you can give it a try and report back it would be nice.

#6 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Also available in: Atom PDF