Bug report #3646

GRASS toolbox: error removing vectors from a mapset under Windows

Added by Giovanni Manghi about 9 years ago. Updated over 8 years ago.

Status:Closed
Priority:High
Assignee:Giuseppe Sucameli
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13705

Description

Since 1.6 (so it works fine under 1.5) every time a user tries to remove a vector map in GRASS toolbox browser using the proper toolbar button results in the following error message

Cannot delete map XXX
command: regio g.remove.exe
vect=XXX

the vector is then not completely removed from the mapset.

Associated revisions

Revision f1d7062c
Added by Giuseppe Sucameli over 8 years ago

Fix remove GRASS vector map from mapset on Win OS (should be fix #3646 together with grass-dev package),
disable refresh button in GRASS browser if a module is running

History

#1 Updated by Giovanni Manghi about 9 years ago

it fails also from the GRASS command line

C:\\>g.remove vect=regio

GRASS_INFO_MESSAGE(3228,1): Removing vector <regio>
GRASS_INFO_END(3228,1)

GRASS_INFO_WARNING(3228,2): Unable to delete file 'C:/Users/gio/GRASS/teste1/teste1/vector/regio/hist'
GRASS_INFO_END(3228,2)

GRASS_INFO_WARNING(3228,3): couldn't be removed
GRASS_INFO_END(3228,3)

GRASS_INFO_WARNING(3228,4): <regio> nothing removed
GRASS_INFO_END(3228,4)

#2 Updated by Giovanni Manghi about 9 years ago

it fails also under qgis 1.5, in fact it depends if the GRASS vector is being displayed in the QGIS TOC. If it is in the TOC then the error message is returned with its consequences, if the vector is not added in the QGIS project then is removed correctly from the mapset.

#3 Updated by Giovanni Manghi about 9 years ago

in qgis 1.6/trunk it fails regardless if the vector was added to the qgis project or not

#4 Updated by hellik - about 9 years ago

Replying to [comment:1 lutra]:

it fails also from the GRASS command line

> C:\\>g.remove vect=regio
> 
> GRASS_INFO_MESSAGE(3228,1): Removing vector <regio>
> GRASS_INFO_END(3228,1)
> 
> GRASS_INFO_WARNING(3228,2): Unable to delete file 'C:/Users/gio/GRASS/teste1/teste1/vector/regio/hist'
> GRASS_INFO_END(3228,2)
> 
> GRASS_INFO_WARNING(3228,3): couldn't be removed
> GRASS_INFO_END(3228,3)
> 
> GRASS_INFO_WARNING(3228,4): <regio> nothing removed
> GRASS_INFO_END(3228,4)

it's maybe a problem in wingrass itself and not in the grass-plugin.

see http://trac.osgeo.org/grass/ticket/1158

in an actual nightly wingrass65-build I have to delete the same vector twice

g.remove [email protected]                                                        
Removing vector <[email protected]>
Kann Datei 'C:\\gisdata\\grassdata/nc_spm_08/g65/vector/mygeol/hist' nicht löschen.
couldn't be removed
<mygeol> nothing removed
(Sun Mar 27 16:58:58 2011) Command finished (0 sec)                             
(Sun Mar 27 16:59:03 2011)                                                      
g.remove [email protected]                                                        
Removing vector <[email protected]>
(Sun Mar 27 16:59:03 2011) Command finished (0 sec)  

#5 Updated by Giovanni Manghi about 9 years ago

so it seems we are stuck here

http://trac.osgeo.org/grass/ticket/1158#comment:15

can someone do what glynn asks, so the bug can be fixed?

#6 Updated by Markus Neteler almost 9 years ago

Giovanni Manghi wrote:

so it seems we are stuck here

http://trac.osgeo.org/grass/ticket/1158#comment:15

can someone do what glynn asks, so the bug can be fixed?

any news on this front?

#7 Updated by Giovanni Manghi almost 9 years ago

I have no idea on how to do what is asked under Windows. I hope that someone will step in because this bug hurts a lot the user experience.

#8 Updated by Giovanni Manghi almost 9 years ago

  • Pull Request or Patch supplied set to No

any news?

#9 Updated by Giovanni Manghi over 8 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed
  • Assignee changed from Redmine Admin to Giuseppe Sucameli
  • Priority changed from Low to High

The issue has been solved upstream in GRASS 6.4.2 svn. We (Faunalia, Giuseppe Sucameli) made the packages to test the fix in OSGeo4w and the issue is fixed indeed.

It was also necessary to make further fixes to the QGIS/GRASS plugin

f1d7062c3ed3474785ca2ef03675397cbfa37d32

in order to avoid further problems, especially under the Windows platform.

The issue can be considered fixed, but only if/when GRASS 6.4.2 (svn) will be available in OSGeo4w (and then subsequently in the standalone installer).

Also available in: Atom PDF