Bug report #3639

Incorrect rendering of rasters at big scales

Added by Goyo D over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13698

Description

When zoomed so that raster pixels are shown as big squares they are shifted. The value tool shows the correct values though. Maybe a floating point issue.

Steps to reproduce:
1. Uncompress the attached file and open the sample.qgs project.
2. Zoom and pan. See how pixels change their locations with respect to the point. Some pixels become rectangles sometimes.

Images showing the problem are also included.

sample.tar.gz - Sample project to reproduce the bug and images. (25.1 KB) Goyo D, 2011-03-18 03:17 PM

History

#1 Updated by Goyo D over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

It seems to be fixed in r15540M so I'm closing this bug.

Also available in: Atom PDF