Bug report #3620

Wrong layer CRS recognition ( the 'Hartebeesthoek94' issue)

Added by Borys Jurgiel over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Projection Support
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13679

Description

Unfortunately r15361 have introduced one huge problem: all layers with correct WGS-84 prj definition are recognized as the 'EPSG:4148 - Hartebeesthoek94' crs. It can be really confusing and annoying for users and I believe we can't release 1.7 with it. Especially if it will be the last release of the 1.x series.

What about trying to find the exact definition and then fallback to the less restrictive comparision?

Associated revisions

Revision 4f08ba70
Added by Jürgen Fischer over 9 years ago

heck, fix #3620

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision c8153fb9
Added by Jürgen Fischer over 9 years ago

heck, fix #3620

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by cgsbob - over 9 years ago

When I first encountered this problem, I was told that I can use

OVERRIDE_PROJ_DATUM_WITH_TOWGS84=NO 

to bypass this problem. Take a look at [http://trac.osgeo.org/gdal/ticket/3450]

#2 Updated by Borys Jurgiel over 9 years ago

I only mean that all the files existing around, that was recognised as well known 4326 should be still recognised as it. With all due respect for EPSG:4148, it's unknown for most users.

#3 Updated by Jürgen Fischer over 9 years ago

please retry with 393e206e (SVN r15503).

#4 Updated by Borys Jurgiel over 9 years ago

Seems to be fixed for OGR layers. Rasters are still affected.

#5 Updated by Jürgen Fischer over 9 years ago

Replying to [comment:4 borysiasty]:

Seems to be fixed for OGR layers. Rasters are still affected.

please try with 59ce32eb (SVN r15508) - unfortunately I don't have a good set of rasters to test with - but it correctly picks EPSG:32633 for tests/landsat.tif...

#6 Updated by Borys Jurgiel over 9 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Seems it's fixed now. Thanks!

#7 Updated by Borys Jurgiel over 9 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

oooops :( Still the same with this file:
http://trac.osgeo.org/qgis/attachment/ticket/3508/l2.zip

#8 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

one more take in c8153fb9 (SVN r15528).

Also available in: Atom PDF