Bug report #3608

crash while adding mapproxy wms layer

Added by Duarte Carreira over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13667

Description

1) Add wms server http://osm.omniscale.net/proxy/service?tiled=true
2) Connect, and answer twice “No” to questions about ignoring advertised url (I supposed this always happens with wms-c services?)
3) Select “osm” layer
4) Click Add
5) QGIS crashes

Using Win 7 32bit, QGIS 1.7 r15458.

Some users reported: 1 it works fine, 1 said 1.6 crashed, 1 that loaded fine but saw all white.

Associated revisions

Revision 42b2a6bd
Added by Jürgen Fischer over 9 years ago

fix #3608

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 94fc6a00
Added by Jürgen Fischer over 9 years ago

fix #3608

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi over 9 years ago

1 that loaded fine but saw all white.

in this case probably the user didn't used the "tilesets" tab to add the layer.

#2 Updated by Giovanni Manghi over 9 years ago

6d06ec30 (SVN r15471) under Windows Seven 32 bit works fine for me.

On the other hand both qgis 1.6 and trunk do crash under Ubuntu 10.04 with the following message

Fatal: ASSERT: "!isEmpty()" in file /usr/include/qt4/QtCore/qlist.h,
line 263
Aborted

#3 Updated by Duarte Carreira over 9 years ago

Replying to [comment:1 lutra]:

1 that loaded fine but saw all white.

in this case probably the user didn't used the "tilesets" tab to add the layer.

lutra: notice that I'm having a crash using the wms service, not the tilesets. tileset are giving me other problems, like not seeing the tiles osgeo:41001. I can only see epsg:4326. But I hadn't reported this yet since I wanted to test more.

#4 Updated by Giovanni Manghi over 9 years ago

You are right:

on both Linux and Windows (qgis 1.6 and trunk) it works fine for me (I see the layers in 4326) if I add the layer trough the "tilesets" tab.

on linux (Ubuntu 10.04) I get the crash if I try to add the layer trough the "layers" tab.

Under Seven 32bit it still does NOT crash and I can even see the layers but I have to unselect first the "ignore GETMAP url" checkbox first.

#5 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 94fc6a00 (SVN r15473).

Also available in: Atom PDF