Bug report #3596

georeferencer broken

Added by Giovanni Manghi over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Redmine Admin
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13656

Description

the commit in r15409 seems to have broken the geoferencer, since the non georeferenced image will not show in the tool window

Associated revisions

Revision c54b8e50
Added by mmassing - over 9 years ago

Fix #3596

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 1d974e8a
Added by mmassing - over 9 years ago

Fix #3596

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by John Tull over 9 years ago

I can confirm this issue. The load raster tool reports that the image is loaded, but it is not drawn in the window.

#2 Updated by mmassing - over 9 years ago

I'll look into this tomorrow.

#3 Updated by Werner Macho over 9 years ago

Replying to [comment:3 mmassing]:

I'll look into this tomorrow.

As far as i remember QGIS were able to load plain jpg (like from a digital cam) before ..
Now QGIS cannot load just a pic (i'm not saying that i want to use QGIS as a picture viewer - just for test ;) ).
I think as long as QGIS does not load "just" pictures .. there will be less chance to fix georeference - because georeference wants to load "just pictures" to add georef info to it ..

just my thoughts about this issue ..
regards
Werner

#4 Updated by Giovanni Manghi over 9 years ago

Radim passed this mail a few days ago

http://lists.osgeo.org/pipermail/qgis-developer/2011-March/013295.html

then he introduced what he called a "ugly" workaround

https://trac.osgeo.org/qgis/changeset/15409/

#5 Updated by mmassing - over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Should be fixed in 1d974e8a (SVN r15482)

Also available in: Atom PDF