Bug report #3592

qgis 1.7 trunk: empty <provider></provider> on qgis 1.6 project with raster in it crash with segfault i solved by...

Added by marcobra - over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:13652

Description

Sysop Ubuntu 10.04.2 32 bits

Load 1.6 project made qgis 15429 crash with segfault

Loaded : MapServer Export (package: mapserver_export)
Warning: QgsRasterLayer::setDataProvider: Data provider is invalid.
ERROR 10: Pointer 'hDS' is NULL in 'GDALGetRasterCount'.

Then i get a segfault

So checking the project xml i see i have the

Checking the project xml i see i have the

<provider></provider>

into raster files

-----------------------
...
<id>21313020080131153612340</id>
<datasource>/home/ubuntu/sit/mapserver/tif/213130.tif</datasource>
<layername>213130</layername>
<srs>
...

&lt;customproperties/&gt;
&lt;provider&gt;&lt;/provider&gt;
....

Solved by replacing all occurences of

<provider></provider>

with

<provider>gdal</provider>

Now old 1.6 project with raster are opened with success.

Thank you

Marco Braida

History

#1 Updated by Giovanni Manghi over 9 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #3594 (that has a patch now)

Also available in: Atom PDF