Bug report #3575

qgis 1.7.0-Trunk Rev. 15398 segfault

Added by marcobra - over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:13635

Description

Hi this is my first bug report here...

i usually compile qgis from trunk every day and today with
qgis 1.7.0-Trunk Rev. 15398 compile fine on Ubuntu 10.04.2 LTS
and start without issue but i get a segfault opening my usual project

Please tell how can i send additional info if requered
Thanks
Marco

History

#1 Updated by Giovanni Manghi over 9 years ago

In has been added raster on the fly reprojection, it may have broke something with projects saved with previous revisions. Please try add the layers in a new project and check if it still crashes.

#2 Updated by marcobra - over 9 years ago

Replying to [comment:1 lutra]:

In has been added raster on the fly reprojection,...

I think there is a typo in your answer i guess you mean 53475e28 (SVN r15396)

If i load a tif with tfw i gen no error and i get no crash

Thanks

#3 Updated by Giovanni Manghi over 9 years ago

Replying to [comment:2 marcobra]:

Replying to [comment:1 lutra]:

In has been added raster on the fly reprojection,...

I think there is a typo in your answer i guess you mean 53475e28 (SVN r15396)

yes

If i load a tif with tfw i gen no error and i get no crash

then your problem is probably caused by the new qgis feature. You can make further tests but I suggest to close this ticket meanwhile.

#4 Updated by marcobra - over 9 years ago

Thanks but the segfault is still here as newbie here why you suggest me to close this ticket...?

Thanks

#5 Updated by Giovanni Manghi over 9 years ago

Replying to [comment:4 marcobra]:

Thanks but the segfault is still here as newbie here why you suggest me to close this ticket...?

The raster reprojection commit was a big one, it is probable that it may have broke the compability with some projects made with previous revisions. But this is not a bug, it is how QGIS will be... so if your tests do confirm it, you can close the ticket.

If you find another reason than leave it open. But if the problem appeared after compiling today my guess is that it is because of the raster OTFR commit.

#6 Updated by marcobra - over 9 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Thanks...

Best regards

Marco

Also available in: Atom PDF