Bug report #3508

Custom projection issues

Added by dr - almost 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Projection Support
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13568

Description

Create custom projection:

+proj=aea +lat_1=52 +lat_2=64 +lat_0=0 +lon_0=105 +x_0=18500000 +y_0=0 +ellps=WGS84 +units=m +no_defs

Open vector layer (in attachment). Enable on the fly CRS transformation and set created custom projection.

Issues:

1. Zoom to layer extent does not work and layer is invisible;

2. Open attribute table, select any row and press "Zoom map to selected rows" button. Layer becomes visible, but if change zoom level with mouse wheel - any features or layer at all disappears from map canvas.

l2.zip (198 KB) dr -, 2011-02-19 11:16 PM

aea_proj_in_grass64.png - Map shown in GRASS 6.4 from -180° to +180° (25.2 KB) Markus Neteler, 2011-04-17 12:22 PM

aea_proj_in_grass64_shifted.png - Map shown in GRASS 6.4 from -50° to+50° (25 KB) Markus Neteler, 2011-04-17 12:23 PM

History

#1 Updated by Maxim Dubinin over 9 years ago

related to #2426

#2 Updated by Markus Neteler over 9 years ago

This is an issue of the global wrap around apparently not handled correctly. For illustration, I have imported the map in GRASS 6.4.1. The global wrap around code is tricky, see here and here for the implementation in GRASS, perhaps useful for inspiration.

#3 Updated by Markus Neteler over 9 years ago

See also #2349

#4 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

duplicate of #2426

Also available in: Atom PDF