Bug report #349

Buffer plugin fails

Added by Gary Sherman almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10408

Description

When buffering a PostGIS layer, the buffer (geoprocessing) plugin fails with:

"Unable to add geometry column to the output table"

History

#1 Updated by Gary Sherman almost 14 years ago

This fix has been tested with:

  • POSTGIS="1.1.1" GEOS="2.0.1" PROJ="Rel. 4.4.9, 29 Oct 2004"

Because of the change in the name of the geometry check constraint created by
addgeometrycolumn (from $2 to enforce_geotype_shape) this fix requires a recent
version of PostGIS. The minimum PostGIS version that will work with this fix is
unknown.

Additional testing is needed by other PostGIS/PostgreSQL version combinations.

#2 Updated by Gary Sherman almost 14 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

#3 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF