Bug report #3404

Measure tool Segment/Total locales are inconsistent.

Added by adbosco - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Gentoo Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:13464

Description

Measure tool reports values formatted into different locales in the Segment window text area and in the Total line edit. A picture is worth a thousand words. Please look at the screenshot (measure.png) attached and you will see what I mean.

This ticket relates to snv qgis_trunk, revision 15021.

Relevant environment variables are set like this:

LC_ALL=""
LANG="pt_BR.UTF-8"

KDE locale setting is deafult (English/American). See the picture attached (kdesystem.png).

measure.png - Measure Tool window with inconsistent number locales. (20.2 KB) adbosco -, 2011-01-12 12:22 PM

kdesystem.png - My locale settings in KDE. (96.8 KB) adbosco -, 2011-01-12 12:23 PM

History

#1 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #2058

Also available in: Atom PDF