Feature request #3370

Support style self-load for spatialite/postgis

Added by aperi2007 - almost 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Canvas
Pull Request or Patch supplied: Resolution:duplicate
Easy fix?:No Copied to github as #:13430

Description

When add a shapefile to the canvas, if there is a style (qml) with the same name of shapefile it is load automatically.

It would be very useful to hav a similar action for a table-layer.

It could be use the same paradigm used for the shapefiles:

Infact as for a shapefile the style to be self-load must be available in the same folder and with the same name of the shapefile but with qml extension,
for a table/view (spatialite/postgis) layer the style , to be self-load, could be available in a table with "_qml" postfix.
For example for the table
"rivers" the style could be retrieve automatically if exist a table with name "rivers_qml", in the same database and same schema.

History

#1 Updated by Jürgen Fischer almost 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #1127

Also available in: Atom PDF