Bug report #3326

Symbolization - Applying/OK new symbol qualities

Added by Mars Sjoden almost 11 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Legend
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13386

Description

Using QGIS 1.6.0 SnowLeopard version with Kyng's Frameworks

I have tried many different shapefiles that seem to work fine in UDIG, GRASS, and ArcGIS.

QGIS hard crashes when I try to change the Symbolization of a feature in the PROPERTIES pane. Clicking APPLY or DONE hard crashes QGIS

I have re-installed QGIS and wiped any previous caches and .plist files from no difference.

10.6.5
Intel Macintosh iMac 24" 3ghz c2d
4gbram

ran memtest (just incase) memory is clear and fine.
ran fdisk file system is fine, no bad blocks etc.

qgis1.6crash.txt Magnifier - crash report (57.5 KB) Mars Sjoden, 2010-12-13 02:29 AM

History

#1 Updated by Giovanni Manghi almost 11 years ago

seems related to #3003

#2 Updated by Mars Sjoden almost 11 years ago

Replying to [comment:1 lutra]:

seems related to #3003

Yah the Symbology Changing crash is similar.

Except it is not random for me. It is every single time. Multiple shapefiles and gpx files.

Is there a way to merge these tickets? I do not know much about this system here.

#3 Updated by Giovanni Manghi almost 11 years ago

Is there a way to merge these tickets? I do not know much about this system here.

they are now cross referenced. The developer that will eventually fix this will close both (if they are related).

#4 Updated by William Kyngesburye almost 11 years ago

No problems here with some simple shapefiles. I think I've seen a few random crashes when changing symbology in the past (1.4, 1.5), but it would work the next time. I haven't had much time to work with 1.6 lately to see if it's any better.

I don't see anything in the crashlog that points to a packaging or build problem.

#5 Updated by Martin Dobias almost 11 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Fixed in ff96fbd3 (SVN r14935).

#6 Updated by Mars Sjoden almost 10 years ago

Glad to hear this was fixed for most people, however no change at my end.

When I finally was able to build from Trunk (r14935) it appeared to be working for the first 5 symbology changes,

However, After those 5 successful symbology changes QGIS would start hard crashing when applying or 'OK' ing a symbol change.

Usually would happen when changing a moderately sized data set with apprx 1000+ features.

Nothing really special about the data sets, poly, line, points... tried some basic online data sets from OSM also.

Most of my data sets are stock from BC Data Warehouse with QGIS processing modifications.

I will try to build QGIS on Linux Mint 11 with the Debug flag set true, maybe there will be an insite there.

Also available in: Atom PDF