Feature request #3320

Delimited text plugin causes crash

Added by Chris Crook about 11 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:Data Provider
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:13380

Description

Following from message on qgis-user list at

http://lists.osgeo.org/pipermail/qgis-user/2010-December/010628.html

relating to QGis crash caused by delimited text plugin. This error appears to be due to reading files with variable number of fields, which is tested in the provider constructor function, but not in the nextFeature function.

The attached patch should fix this. It takes a slightly different approach to previously - instead of ignoring lines with the wrong number of fields, it adds blank strings to ensure that there are the expected number.

Also fixes a problem with line number counting.

delimited_text_crash_fix.patch Magnifier (3.41 KB) Chris Crook, 2010-12-11 10:41 AM

History

#1 Updated by Gary Sherman about 11 years ago

Patch applied at b52d0743 (SVN r14891). Thanks!

#2 Updated by Gary Sherman about 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF