Feature request #3291

when digitizing, show vertexes of the layer, you catch from

Added by Gerhard Spieles almost 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:13351

Description

Hi,

a lot of thanks for the popup window to change the catching options since ver. 1.7.

When digitising objects, you do not see vertexes of the backgroundlayer, you catch from. In result, vertexes will forget and the digitised objects are not prefect.

In the window "catchingoptions", it would be goud to have an option field "show vertexes" of the layer, you catch from.

An example is in the the attached file.

Thanks for a solution.
Gerhard

show_vertexes_of_a_layer_when_catch_from.jpg (95.4 KB) Gerhard Spieles, 2010-12-03 01:02 PM

History

#1 Updated by Gerhard Spieles over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Copy content fom ticket 2626

Hi,

thanks for your work. I have installed trunk 0a89f197 (SVN r15329) (trunk nr. 81). My suggestion is to optimize catching function. In the attached examples, i want to digitize a new polygon in the layer "testpolygoncadfunctions". I catch from the vertexes from the layer "Flurstuecke" The problem is, that normaly, I do not see the vertexes of the layer "Flurstuecke" (see attached picture 1). The result of the digitzed polygon is not precise.

I only see the vertexes of the layer "Flurstuecke", when I set the layer "Flurstuecke" in the edit mode. That is not good, because I dont want edit the layer "Flurstuecke". Therfore, i proposed, to add in the window "catching options" a chekbox to see the vertexes of the layer, you catch from, in my example, I want to see the vertexes of the layer "Flurstuecke".

Changed 6 days ago by gespiel
■attachment see_vertexes_layer_catching_from_1.jpg added
Changed 6 days ago by gespiel
■attachment see_vertexes_layer_catching_from_2.jpg added

Changed 6 days ago by pcav ¶
You can see them if you set the other alyer as editable. If this solves for you, please close this ticket.

From gespiel
---> It is not the best solution to set the layer you catch from in edit mode, but i accept it and close the ticket.

Also available in: Atom PDF