Bug report #3270

NEW Symbology - Transparent polygons are not transparent when selected

Added by pinux - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:13330

Description

With the old symbology when a layer is transparent, if an object is selected it becomes yellow and is also transparent. With the new symbology the selected object is not transparent.

History

#1 Updated by Giovanni Manghi almost 10 years ago

I disagree that this is a bug. In fact I think the bug is as it behave in the old symbology.

In the old symbology a 100% transparent object is "unselectable" in the canvas, as the transparency is applied also to the selection color. This for me is wrong/not useful. There is/was a ticket about this before the new symbology was introduced.

I would like to ear from Martin and others about this.

#2 Updated by Giovanni Manghi almost 10 years ago

How other GIS software behave?

#3 Updated by pinux - almost 10 years ago

Replying to [comment:2 lutra]:

How other GIS software behave?

In Arcmap 9.3 a selected object remain transparent and with the same color of an unselected object only the outline is highlighted.

I think that it should be transparent, let's assume that I want to edit a layer and I need to have it transparent so that I can see the layers under it. Then I want to cut 1 object in 2, I select the object that I want to cut with the tool "Split features" (I selected it because I want to cut only that object), then i start to cut that object but I just can't see what is under the selected object.

#4 Updated by Giovanni Manghi almost 10 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Good news, I didn't even realized that now in trunk (maybe also in 1.6) you can set the transparency level of the selection color. You can do it in both the general options and in the project properties. When you choose the selection color you have also a "alpha channel" spinner.

This way, in the new symbology, you can see transparent as you want a selection of a 100% transparent geometry.

I believe that this solves your problem. Reopen if necessary.

In Arcmap 9.3 a selected object remain transparent and with the same color of an unselected object only the outline is highlighted.

I think that it should be transparent, let's assume that I want to edit a layer and I need to have it transparent so that I can see the layers under it. Then I want to cut 1 object in 2, I select the object that I want to cut with the tool "Split features" (I selected it because I want to cut only that object), then i start to cut that object but I just can't see what is under the selected object.

Also available in: Atom PDF