Bug report #3261

Rendering bug

Added by Chris Crook almost 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Canvas
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13321

Description

I've encountered a bug when viewing a line string layer which causes a large portion of the map canvas to be covered with the line colour when zoomed to a specific view. The data appears normallty when zooming in or out, or otherwise changing the canvas/view relationship.

I've attached a png screenshot and a zip file containing the QGIS project and spatialite database. Because the bug depends on the canvas size you may not be able to replicate immediately from this dataset. You should be able to infer the map canvas size from the screen shot.

This could be related to ticket 2915, which demonstrates a glitch plotting polygons.

render_bug.png - Screenshot showing bug (86.2 KB) Chris Crook, 2010-11-28 05:39 PM

render_bug.zip - Project and data file (9.39 KB) Chris Crook, 2010-11-28 05:40 PM

History

#1 Updated by Anne Ghisla over 9 years ago

Can you give the spatial extent of the view, e.g. saving it as spatial bookmark?

Is it happening also on other platforms? As now, I can't reproduce it with QGIS f8e10a33 (SVN r15725) on Fedora, but I'd wait for more info on the canvas extent.

#2 Updated by Maxim Dubinin over 9 years ago

can't reproduce it as well on winXP f42443c9 (SVN r15701)

#3 Updated by Chris Crook over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Replying to [comment:2 gislab]:

can't reproduce it as well on winXP f42443c9 (SVN r15701)

I can no longer reproduce the bug either (on 1.7.0). I'm guessing some other patches along the way have fixed it. I've reset the status to fixed.

Thanks for looking at it.

Also available in: Atom PDF