Bug report #325

Anti-virus crashed QGIS

Added by watry-coaps-fsu-edu - almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:10384

Description

My Anti-Virus Program is flagging QGIS for a virus whenever it
encounters the file "\\grass\\bin\
.out.mpeg.exe. It considers this
to be a hidden executable extension. It seems to be happening
when I enable labels and then zoom into an area.

Following this, QGIS crashes.

The Anti-virus program is AVG

History

#1 Updated by Martin Dobias almost 14 years ago

Shouldn't you report this to the company producing the antivirus? I have no idea what we can do to resolve this problem.

Following this, QGIS crashes.

What does this mean? QGIS crashes when you start it or when?

#2 Updated by Gavin Macaulay - almost 14 years ago

\\grass\\bin\
.out.mpeg.exe is a Grass file, and has little to do with qgis (except that the grass plugin in qgis may use it via grass). More information on how qgis crashes would be helpful.

#3 Updated by Gary Sherman almost 14 years ago

Try disabling the anti-virus program and see if QGIS still crashes

#4 Updated by anonymous - almost 14 years ago

1) It's a Microsoft Windows design flaw. GRASS is oriented to Unix like systems, where program names like "r.out.mpeg", "readme.txt" are normal. On Windows You can not have program named "readme.txt", so it's fixed by adding additional .exe at end of every GRASS executable file. Solution was to whitelist GRASS directory in your antivirus software. You can search for thread about this issue in GRASS developer list.

2) It's bug in QGIS. Antivirus software block's access to "infected" GRASS executable file, but, most likely, QGIS still tries to use it (I don't have Windows at hand to test it). Bug should be somewhere in code, that looks for available GRASS modules.

#5 Updated by Redmine Admin almost 14 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

I am convinced that QGIS crash was not caused by antivirus program.
The module r.out.mpeg is never called by GRASS plugin
and GRASS modules are stand alone programs so if they crash
it cannot crash QGIS.

I am going to change the ticket to invalid because that crash
was caused by something else which is not described in this report.

Radim

#6 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF