Bug report #322

Delimited text plugin doesn't work

Added by Redmine Admin almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:10381

Description

It is unable to add layer form delimited text file. Points coordinates and values are not properly interpreted. For expale -- text file (see below) which was successfully imported in 0.7.4 is not possible to import in current svn version (fails also in WINDOWS preview2)

Content of simple text delimited file:

x y value
12 15 18
64 33 45
77 12 66

test.txt Magnifier (37 Bytes) Redmine Admin, 2006-10-01 03:56 AM

bug_pic1.png (78.4 KB) Redmine Admin, 2006-10-01 03:57 AM

History

#1 Updated by Gavin Macaulay - almost 14 years ago

Works for me in latest svn. In what way doesn't it work for you?

#2 Updated by Redmine Admin almost 14 years ago

1. Click "Add delimited text layer" - choose test.txt (attached below) as input file, space ( ) as delimiter, then click Parse and choose x fied as X coordinate and y field as Y coordinate and finally click Add layer button
2. On the canvas you can see only one point (not all three, which really exist -- see attached screenshot). Try "Full zoom" button -- it won't help. If you play little with Pan you can explore also two missing points.
3. Click "Attribute table" icon. As you can see the table is emty (see attached screenshot) althogh it wouldn't be.
Behaviour described above could be observed in (Linux) as well as in Preview2 (Windows), although it worked in 0.7.4 without these complications.

#3 Updated by Gavin Macaulay - almost 14 years ago

The problem with points that are exactly on the boundary not being displayed is fixed in svn eab31648 (SVN r5906)

#4 Updated by Gavin Macaulay - almost 14 years ago

Can you try this again with the latest svn version? I managed to duplicate the problem a few days ago, but it worked fine for me just now...

#5 Updated by Redmine Admin almost 14 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

In 7ee9b7c5 (SVN r5911) it works for me too. Thanks for advance.

#6 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF