Bug report #3167

calculation of ruggedness

Added by Trevor Wiens almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:13227

Description

In browsing the code for ruggedness I found something odd.

The formula is missing division by n prior to the execution of sqrt if it is supposed to be standard deviation from the centre pixel.

Since there is no documentation on the formula that was intended, I don't know if this is intentional or a bug.

History

#1 Updated by Marco Hugentobler almost 10 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Ruggedness index is calculated according to Riley et al. 1999 (see corrected formula in http://www.fw.msu.edu/~rileysh2/Terrain%20Ruggedness%20Index.pdf). There is no division by the number of pixels, only the root of the squares is taken.

Also available in: Atom PDF