Bug report #3130

Internal SVG resources not selectable on OS X

Added by William Kyngesburye about 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:13190

Description

When asked to choose an SVG file for symbology (one place I ran into this, there may be others), it's a normal file chooser. On OS X, you cannot navigate into an application package, so it's not possible to select any of the builtin SVG files.

One nice solution would be to show a list of builtin SVG to choose from. Since there are a lot, and organized in subfolders, a menu would be cumbersome. A list box, hierarchically organized, would be better. Even better, disclosure triangles to collapse/expand folders. Of course, it would need an option to choose an external user file.

If that's not possible or practical, I'll have to change the install process to install the SVG externally in /Library/Application Support (or similar in a users home). This would then require an installer for packaging QGIS for distribution (no drag-n-drop install).

History

#1 Updated by William Kyngesburye over 9 years ago

  • Resolution set to invalid
  • Assignee deleted (nobody -)
  • Status changed from Open to Closed

Er, so it's already implemented, very likely for a long time. Don't know how I missed this.

Also available in: Atom PDF