Bug report #3076

OSM plugin: python error clicking on "load OSM from file"

Added by Giovanni Manghi about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13136

Description

This happens on trunk under Ubuntu 10.04. Under trunk/osgeo4w does not seems to happen:

Traceback (most recent call last):
  File "/usr/share/qgis/python/plugins/osm/OsmPlugin.py", line 199, in loadOsmFromFile
    self.dlgLoad=OsmLoadDlg(self)
  File "/usr/share/qgis/python/plugins/osm/OsmLoadDlg.py", line 57, in +init+
    item.setFlags( Qt.ItemIsSelectable | Qt.ItemIsUserCheckable | Qt.ItemIsEnabled)
[[AttributeError]]: 'module' object has no attribute 'ItemIsSelectable'

History

#1 Updated by Borys Jurgiel about 10 years ago

It's caused by the line 19: from PyQt4 import *

from PyQt4.QtCore import *
Qt

<class 'PyQt4.QtCore.Qt'>

from PyQt4 import *
Qt

<module 'PyQt4.Qt' from '/usr/lib/pymodules/python2.6/PyQt4/Qt.so'>

Is this import used anywhere at all?

#2 Updated by Giovanni Manghi about 10 years ago

the same message shows when clicking on "download" in the "download osm data" dialog.

#3 Updated by Giovanni Manghi about 10 years ago

works fine under trunk/osgeo4w

#4 Updated by Giovanni Manghi about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Just recompiled from source and this error seems to be gone.

Also available in: Atom PDF