Bug report #3056

(OsX) clicking on the "spatial query" plugin icon does nothing

Added by Giovanni Manghi about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:13116

Description

Seems also that since 1.5 other plugins (3rd party, python) are affected. Has been reported to me (I don't have a Mac) that for example a user cannot show the settings of the Interactive Identify plugin or the the settings of the Google Layers plugin.

History

#1 Updated by William Kyngesburye about 10 years ago

I found that googleLayers settings does not work in OS X 10.5 (I did not find any Interactive Identify plugin). No errors in the console log.

In 10.6 it works. Though the settings window is using a tiny compressed font, making it hard to read. Maybe this is a clue - non-standard GUI?

Main difference between systems: python 2.5 vs. 2.6.

#2 Updated by Giovanni Manghi about 10 years ago

Replying to [comment:1 kyngchaos]:

(I did not find any Interactive Identify plugin).

it is among the standard 3rd party repositories

http://ggit.metu.edu.tr/~volkan/plugins.xml

In 10.6 it works. Though the settings window is using a tiny compressed font, making it hard to read. Maybe this is a clue - non-standard GUI?

Main difference between systems: python 2.5 vs. 2.6.

do you confirm then that also a core plugin spatial query does not work (at least on certain configurations)?

#3 Updated by William Kyngesburye about 10 years ago

Ah, right. I didn't connect the bug title with the description as being separate content.

Spatial does not do anything. This makes it not just a python issue.

Maybe there's a Qt problem on Leopard. I currently use the Qt binaries for Qgis on Snow Leopard, and build my own Qt on Leopard so I can get a PPC Cocoa Qt. I'll try the Qt binaries for Leopard and see if that helps.

#4 Updated by William Kyngesburye about 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

ding! That was it. Qt compiled from source wasn't working properly. This is probably what is causing some other problems on Leopard. I'm going to close this as invalid and build a new Qgis 1.5 package for Leopard.

Unfortunately, this means I can't make a PPC Mac Qgis. There were issues (I don't remember what) using Qt Carbon (the only "official" binaries available for PPC). Major problem for me actually, since we still have a lot of PPC Macs where I work, and I'm trying to get Qgis into our workflow. I'll have to look at Qt Carbon again...

Also available in: Atom PDF