Bug report #303

rasters conatining nulls are all black

Added by Redmine Admin about 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gavin Macaulay -
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10362

Description

Open the attached Gtiff in QGIS. It will be all black though querying it proves it has wide data range. Propably the reason is QGIS can't handle null value it contains.

The Gtiff opens fine in OpenEV viewer.

Maciek

hipso03.dem_GH_selekt_grow100.tif.bz2 (22.9 KB) Redmine Admin, 2006-09-24 06:39 AM

History

#1 Updated by Gavin Macaulay - almost 14 years ago

Initial partial fix in e260cc13 (SVN r5999). At least the nulls are plotted transparent now. Qgis still gets comfused when working out the colour mapping. More to come.

#2 Updated by Gavin Macaulay - almost 14 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in e81f6320 (SVN r6000).

#3 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF