Bug report #3022

vertex markers disappear when clicking the "save edits" icon plus a more serious issue

Added by Giovanni Manghi about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13082

Description

Pick a vector, toggle editing, make a change (like moving a feature) and then click "save edits", the vertex markers will disappear.

If you make this test with the "node tool", for example moving a node, the resulting effect is even worst:

select a line or a polygon with the "node tools", move a vertex and click "save edits". The vertex markers will disappear.

Now move again a vertex: the blue square will move, but the adjacent lines will not (at this point you can try save edits but it will be as the vertex wasn't moved).

This happens only the first time you try move a vertex, because if you try again the tool will work fine.

Tested with trunk under both linux and windows.

Associated revisions

Revision 816ffb81
Added by Jürgen Fischer about 10 years ago

fix #3022

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 635117c9
Added by Jürgen Fischer about 10 years ago

fix #3022

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 635117c9 (SVN r14252).

Also available in: Atom PDF