Bug report #2939

Terrain Profile plugin crashes QGIS on Windows

Added by Micha Silver about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12999

Description

The Terrain Profile plugin correctly creates a plugin but then QGIS crashes.
The bug occurs only on Windows.

see also http://lists.osgeo.org/pipermail/qgis-developer/2010-August/010673.html

History

#1 Updated by Borys Jurgiel about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

JEF, why do you take my plugin from me? ;-)

Fixed in v 0.2.2 by disabling coordinate tracking in Windows. The crash was caused by QwtPlotPicker. It's an external plugin, anyway.

#2 Updated by Jürgen Fischer about 10 years ago

Replying to [comment:4 borysiasty]:

It's an external plugin, anyway.

ah, that explains it. I thought was a bug in the raster terrain plugin.

Also available in: Atom PDF