Bug report #2924

psycopg2 error

Added by darioqn - about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12984

Description

when trying to use the PostGIS MANAGER, reports the following error:

Could not import python module 'psycopg2's for communication with PostgreSQL database.

Without it you will not be able to run PostGIS manager. Need help

History

#1 Updated by darioqn - about 10 years ago

  • Status changed from Open to In Progress

#2 Updated by Jürgen Fischer about 10 years ago

  • Status changed from In Progress to Open

The standalone installer doesn't contain psycopg2 (and pyqwt5). The OSGeo4W repository does.

#3 Updated by Giovanni Manghi about 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Replying to [comment:4 jef]:

The standalone installer doesn't contain psycopg2 (and pyqwt5). The OSGeo4W repository does.

psycopg2 can be downloaded here (for standalone installer)

http://www.stickpeople.com/projects/python/win-psycopg/

#4 Updated by Jürgen Fischer about 10 years ago

Replying to [comment:5 lutra]:

Replying to [comment:4 jef]:

The standalone installer doesn't contain psycopg2 (and pyqwt5). The OSGeo4W repository does.

psycopg2 can be downloaded here (for standalone installer)

http://www.stickpeople.com/projects/python/win-psycopg/

What's wrong with the OSGeo4W repository? http://download.osgeo.org/osgeo4w/release/python/psycopg2/psycopg2-2.0.6-1.tar.bz2

#5 Updated by Giovanni Manghi about 10 years ago

nothing, just pointed that the package can be found in different places. I also forgot that now the standalone installer is based on osgeo4w packages.

Also available in: Atom PDF