Bug report #2894

Mapserver export: mangles shapefile paths in mapfile (layerid=0)

Added by Sandro Santilli over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Richard Duivenvoorde
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12954

Description

When exporting a project file to mapserver's mapfile the paths to shapefiles (DATA "/path/...") gets written with a "|layerid=0" substring appended, making them all unresolvable to mapserver.

The substring seems to be also in the project file itself, and works fine there (<datasource>) just needs to be split before writing to mapfile.

Associated revisions

Revision 014f5688
Added by Jürgen Fischer over 11 years ago

fix #2894

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 75ce1bce
Added by Jürgen Fischer over 11 years ago

fix #2894

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 75ce1bce (SVN r13938).

Also available in: Atom PDF