Bug report #2876

bring back raster legend icons

Added by Giovanni Manghi over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Map Legend
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12936

Description

Icons have been disabled in r13899 because of performance problems while opening projects with many rasters.

Icons are nevertheless very useful.

History

#1 Updated by luca76 - over 10 years ago

For me icons for raster image are not too useful.

Why should QGIS draw an icon that represent a, for example, 5000x5000 pixel raster in a space of 16x16?

QGIS should use a simple icons for all rasters...

#2 Updated by Giovanni Manghi over 10 years ago

Why should QGIS draw an icon that represent a, for example, 5000x5000 pixel raster in a space of 16x16?

because when you do raster analisys your rasters (not normal orthophotomaps or militar maps) normally have very different colormaps and with icons they are EASILY identified in the legend.

#3 Updated by William Kyngesburye over 10 years ago

Here's my notes, for the record:

It seems to only affects rasters without overviews. I did a test with a single 1 GiB JP2 and it generates the legend icon nearly instantaneously. A 1.3 GiB tiff without overviews takes a long time, yet the same with overviews is fast. A 200MiB tiff without overviews has a noticable delay, but it's not horrible.

Though the original issue is a small 14MiB vrt with jp2 images, zooming and panning are not affected. Maybe there's something else with a vrt that slows down the legend generation?

#4 Updated by Marco Hugentobler over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Ok, there is now an option to disable raster icons in case of performance problems (btw., those icons are 32x32 )

Also available in: Atom PDF