Bug report #286

Problems in Windows version

Added by Martin Dobias about 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:-
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10345

Description

Qgis 0.8 preview 2 for Windows needs following additions:
  • manuals for Grass programs in docs/html direcotory
  • distribution of MSYS - to enable usage of Grass shell

History

#1 Updated by Redmine Admin about 14 years ago

MINSYS not MSYS

#2 Updated by Martin Dobias almost 14 years ago

Moved from ticket #317:
  • developers photos in the Help>Info>Developers

btw. it's MSYS not MINSYS ;-) see http://www.mingw.org/

#3 Updated by mariate-forwild-umass-edu - almost 14 years ago

I am using windows 2000.

When I work with QGIS 0.8 preview 1, I can use the GRASS shell, but I am unable to open it in the QGIS 0.8 preview 2. Is there anything I have to add to keep using preview 2 with the GRASS shell?

#4 Updated by Martin Dobias almost 14 years ago

Update (test build from 29.november 2006):
  • AUTHORS and SPONSORS file must be copied to share/qgis/doc/ directory
  • with Qt 4.2.0 it did't load developer photos - with Qt 4.2.1 it worked for me
  • new picture of Denis Antipov should be used - previous was XPM with JPG extensions and windows Qt has a problem with that (fixed in )
  • manual for GRASS are present but don't show up in manual tab in grass toolbox
  • grass shell fails to start: msys.bat doesn't like to be installed in path with spaces. What about running directly rxvt or sh?
  • MSYS distribution could be smaller: most commands are not going to be used (ps, mount, vim ...)

#5 Updated by Martin Dobias almost 14 years ago

More missing stuff:
  • QGIS help viewer (+ qgis_help.db needs update)
  • MapServer export utility
Providers and plugins:
  • Postgres provider fails to load
  • some providers (gpx, wfs, wms) and plugins (geoprocessing, georeferencer, gps, spit, wfs) are not compiled

#6 Updated by Martin Dobias almost 14 years ago

From ticket #328:

  • GDAL binaries must be included in distribution otherwise r.out.gdal won't work

#7 Updated by Tim Sutton almost 14 years ago

The msys shell issue should be fixed now (rev 6187)

#8 Updated by frdcn-hotmail-com - almost 14 years ago

Connect button in SPIT is always deactivated.

#9 Updated by Gary Sherman almost 14 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

There are too many separate issues identified throughout this bug report. The initial issues are solved, as are most of the ones subsequently mentioned in the comments. Connect button is disabled because connects are automatic. Why it shows up on the dialog I'm not sure.

Please file a separate ticket for each issue (you can use one ticket for closely related issues, like the original purpose of this ticket).

#10 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF