Bug report #2847

mapserverexportplugin bug: layers with same name mix up data/filter statements

Added by Richard Duivenvoorde about 11 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Richard Duivenvoorde
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12907

Description

see http://lists.osgeo.org/pipermail/qgis-developer/2010-June/010346.html

it appears that 2 postgres layers with the same name, but if one of them has a where-clause applied get both the same FILTER statement in the mapfile

History

#1 Updated by Richard Duivenvoorde about 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 06f15b15 (SVN r13845)

it appears that it's not a typical postgres problem, but a problem of qgis layers having the same (display)name.

the names were used as keys in a layerlist for map-layer definitions, and used as (non unique!) layer names for the mapfile.

both bugs:
because the keys where not unique only the last layer definition was used;
and map files generated contained layers with non unique files

both fixed

Also available in: Atom PDF