Bug report #284

Building pyramids with magphase method cause corrupt resampled images

Added by creeping - about 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:Rasters
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10343

Description

On win32 preview release 2 building pyramids with the magphase method causes corrupt resampled images.

resample_gone_wrong.gif (27 KB) creeping -, 2006-09-22 12:35 AM

History

#1 Updated by creeping - about 14 years ago

grap the file from here if you want to see the original source image: http:///creeping.orcon.net.nz/qgis/260_t19c.7z

#2 Updated by Gary Sherman almost 14 years ago

This option has been removed from the pyramid generator for version 0.8. This issue is moved to 0.9 for reconsideration and further investigation.

#3 Updated by Tim Sutton almost 13 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

A while ago I removed magphase option from the raster properties UI so this issue should no longer occur. I added a note in qgsrasterlayer.cpp (73da80f4 (SVN r7324)) too:

NOTE this (magphase) is disabled in the gui since it tends
to create corrupted images. The images can be repaired
by running one of the other resampling strategies below.
see ticket #284

I am closing this ticket.

#4 Updated by Anonymous about 11 years ago

Milestone Version 0.9.1 deleted

Also available in: Atom PDF