Bug report #283

Polygon & multipolygon shape file crashes qgis

Added by creeping - almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:Vectors
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:10342

Description

win32 preview 2 crashes when shape vector file is loaded. See attached file.

History

#2 Updated by Marco Hugentobler almost 14 years ago

This seems to be a problem of the windows version. I tried it with the current svn version on Linux and I could load and view this shapefile without any problems.

#3 Updated by Redmine Admin almost 14 years ago

Works for me in 0.8.0 Preview2 (Windows) on Windows XP Proffesional SP2. Try to create qgis.bat file for executing qgis

Content of qgis.bat

c:\\path\\to\\your\\qgis.exe
PAUSE

It should prevent you from closing window with debug info which may help to diagnose the problem with crashing.

#4 Updated by Redmine Admin almost 14 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Works for me in QGIS 0.8.0Preview 2 and also in latest Tim's Windows testbuild and also in all my Linux builds.

#5 Updated by creeping - almost 14 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (worksforme)

Hi this still crashes on my winxp sp2 machine :( I haven't got a debug build so I can;t give anymore information. Maybe the next windows release should have debug info.

#6 Updated by Martin Dobias almost 14 years ago

Hi, here you can get also testing debug version of qgis:

http://qgis.org/uploadfiles/testbuilds/

Please try again and give us some feedback.

#7 Updated by Martin Dobias almost 14 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

Two weeks no feedback, I'm closing this one.

#8 Updated by creeping - almost 14 years ago

Thanks, I have tested in Tims latest win32 build and the file does not crash qgis anymore :)

#9 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF