Feature request #2824

label color lost when canceling

Added by fhof - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:12884

Description

  • Let's have a vector layer, say containing surfaces.
  • Go to the layer properties, tab "Label" (2nd one).
  • Check "Display the labels", assign a field, and define a font color (for ex. dark blue).
  • Click on the "Color" button again, then click "Cancel".
  • Click on the "Color" button again, the color is back to black
  • The font color is also lost when clicking "Cancel" in the font definition window. The reset of the color also happens when the color has already been applied and saved.

bug2824fix.diff Magnifier - Proposed patch; it's not tested, sorry, because I was unsuccessful at installing all dev tools (1.7 KB) fhof -, 2010-06-18 05:36 AM

History

#1 Updated by fhof - over 10 years ago

I would be grateful if someone can test or compile for me the correction's proposal for this bug and also for #2784. Thanks.

#2 Updated by Martin Dobias over 10 years ago

fhof: what's your real name? To give you the credits if the patch will be applied.

#3 Updated by fhof - over 10 years ago

Replying to [comment:3 wonder]:

fhof: what's your real name? To give you the credits if the patch will be applied.

Florian Hof

#4 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

applied in 32aed70c (SVN r13857). Thanks.

Also available in: Atom PDF