Bug report #2817

Save as Image using gif only writes world file

Added by Richard Duivenvoorde over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Canvas
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12877

Description

Trying to write current mapcanvas as an image of type GIF (using menu 'File/Save as Image') will write a foo.gifw world-file, but not the corresponding foo.gif.

Tested on trunkversion on both Windows (osgeo4w dev build) and on Ubuntu 10.04 (r13741).

I also tried to use the MapCanvas.saveAsImage-python to write a gif-file, and that also resulted in only the worldfile.

Associated revisions

Revision dbdeca2c
Added by Jürgen Fischer over 11 years ago

fix #2817

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 6878a84d
Added by Jürgen Fischer over 11 years ago

fix #2817

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Looks like Qt does only support reading GIFs, but not writing GIFs, but QGIS assumed that it could also write what it reads. Fixed in 6878a84d (SVN r13747).

Also available in: Atom PDF