Feature request #2813

msvc compilation failure

Added by orgads - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Build/Install
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:12873

Description

Hello,

When trying to compile on msvc, using flex and bison from msys, I'm receiving some error messages regarding the lexer. Some messages are about missing unistd.h, and one message is missing isatty(int) function.

I found the caused, and attached a patch for it. Please review and accept it.

Thanks,
- Orgad

qgis-lexer.patch Magnifier - patch for src/core/qgssearchstringlexer.ll, that enables compiling on msvc (468 Bytes) orgads -, 2010-06-16 05:25 AM

History

#1 Updated by Jürgen Fischer over 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Thanks. Applied in 862209bb (SVN r13741).

BTW GnuWin32's flex works without that patch on MSVC (and includes an unistd.h).

Also available in: Atom PDF