Bug report #2799

QGIS is painfully slow on large datasets!

Added by sandinog - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12859

Description

I tried using QGIS with a fairly large dataset (all parcel polygons, roadway centerline lines, and street light points in Sacramento County, California (about 105 Mbytes of shapefiles, 155 Mbytes of attached database information). Every re-rendering took so much time!
1. It seems like the program is doing too much 'behind the scenes,' like it should use scale and the window size to re-render what the user can see, and not worry about what's off-screen, at least until a change of window coordinates (pan) or change of scale (zoom) is made.

2. I'm willing to upload the dataset I've been using (although the data owners don't really want the databases showing up all over the net), but given the size, I can hardly e-mail them.

Until the program can handle larger datasets, its going to remain a toy and a nice idea, but not a viable alternative to ArcGIS.

History

#1 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #1978

#2 Updated by Giovanni Manghi over 10 years ago

Try use the "cache rendering" and also have a look here

http://blog.qgis.org/node/144

hopefully the problem will be solved as late as by the end of the summer thanks to Martin D. and GSoC.

Also available in: Atom PDF