Bug report #2787

Value Tool crashes with GRASS Rasters

Added by andre mano over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:ghislainp -
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12847

Description

When I import a Raster to QGIS through GRASS, with Value Tool Plugin Activated, it gives the following error message

An error has occured while executing Python code:

Traceback (most recent call last):
File "/home/alt-shn/.qgis/python/plugins/valuetool/valuewidget.py", line 134, in printValue
self.ymin=min(self.ymin,cstr.minimumValue())
AttributeError: 'NoneType' object has no attribute 'minimumValue'

Python version:
2.6.4 (r264:75706, Dec 7 2009, 19:02:09)
[GCC 4.4.1]
++++++++++++++++++++++++++++++++++++++++++++++

Furthermore, the error message repeats itself everytime I click on the "close" Button and I have no choice but to shut down and restart QGIS

History

#1 Updated by Giovanni Manghi over 9 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Olá André,

this is unfortunately a known problem. The GRASS raster provider has changed and fixed a few nasty bugs, but had broken a few other things, among them there is the value tool plugin. In any case the plugin is a 3rd party one, so its bugs nust be reported directly to the author and/or to the dev mailing list.

Cheers!

#2 Updated by Jürgen Fischer over 9 years ago

BTW it doesn't crash. valuetool should ignore grass raster layers (at least for now). the error message only appears when you move the mouse pointer inside the map canvas, so you can move it outside, close the error message using the keyboard and disable valuetool in the plugin manager.

#3 Updated by Jürgen Fischer over 9 years ago

Replying to [comment:3 jef]:

BTW it doesn't crash. valuetool should ignore grass raster layers (at least for now).

Looks like the current version already does. I made a patch that adds support for grass rasters: http://lists.osgeo.org/pipermail/qgis-user/2010-June/008872.html

Also available in: Atom PDF