Bug report #2770

crash when zooming to layer extent

Added by ScottParker - over 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12830

Description

- using Albers coordinate system - zoom to layer extent of gpx file works OK
- change to latlong WGS84
- now zoom to layer extent causes QGIS to crash with "needs to close" message

zoom to layer extent works OK with other gpx files

testing4GM.gpx (11.1 KB) ScottParker -, 2010-06-02 05:11 PM

testing2.qgs (2.39 KB) ScottParker -, 2010-06-02 05:13 PM

History

#1 Updated by Giovanni Manghi over 11 years ago

Please attach gpx track or add a link where it is possible to download it.

#2 Updated by ScottParker - over 11 years ago

I have tried to reduce the datasets and sequence required to reproduce the bug but this is the best I can do.

-start with testing2.qgs (NAD83/ CA Albers EPSG 3310)

-add http://atlas.ca.gov/casil/imageryBaseMapsLandCover/baseMaps/drg/30x60_minute_series_albers_nad83_untrimmed/f38119a1.tif (nothing smaller seems to cause the problem)

-add testing4GM.gpx

-change to WGS84 EPSG 4326

-select testing4GM and Zoom to layer extent

#3 Updated by Giovanni Manghi over 11 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

A few points:

*) the project was made with qgis 1.0.2, if you are using such version you should specify that, not "head", in the ticket.

*) the problem should be duplicate of #2457, you may want to add there new findings about this problem. Reopen if necessary.

*) in any case you cannot reproject rasters in qgis, but I agree that qgis should not crash in this situations

#4 Updated by Giovanni Manghi over 11 years ago

see also #2457

#5 Updated by ScottParker - almost 11 years ago

I verified the fix with this data in case the fix for #2457 did not cover this one. It does not reproject on the fly (I did not expect on the fly.) but it does not crash as before.

Thanks for fixing this.

Also available in: Atom PDF