Bug report #273

compile error

Added by anonymous - about 15 years ago. Updated about 15 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Gentoo Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10332

Description

Followed instructions for bug report in README and went to URL

http://sourceforge.net/tracker/?group_id=55820&atid=478378

Got this:

Permission Denied

Access to this page is restricted (either to project members or to project administrators) and you do not meet the requirements to access this page. Please contact the administrator of this project for further assistance.

Compile error message that I wanted to send you was:

g++ -DHAVE_CONFIG_H -I. -I. -I.. -DPREFIX=\\"/usr\\" -DPLUGINPATH=\\"/usr/lib/qgis\\" -DPKGDATAPATH=\\"/usr/share/qgis\\" -I/usr/include -g -O2 -I/usr/qt/3/include -D_REENTRANT -DQT_THREAD_SUPPORT -I/usr/include -DNO_DEBUG -I/usr/include -I../widgets/projectionselector/ -g -O2 -MT libqgis_la-qgisapp.lo -MD -MP -MF .deps/libqgis_la-qgisapp.Tpo -c qgisapp.cpp  -fPIC -DPIC -o .libs/libqgis_la-qgisapp.o
qgsproject.h:98: error: extra qualification 'QgsProject::' on member 'dirty'
qgsproject.h:100: error: extra qualification 'QgsProject::' on member 'dirty'
qgsrasterlayerproperties.h:72: error: extra qualification 'QgsRasterLayerProperties::' on member 'pbnHistRefresh_clicked'
qgsprojectproperties.h:63: error: extra qualification 'QgsProjectProperties::' on member 'isProjected'

History

#1 Updated by Gavin Macaulay - about 15 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

We no longer use sourceforge, and I've now updated the README file to reflect this. Thanks.

The compile problem can be resolved by removing the QgsProject:: text from the lines and files where the compiler is complaining. This problem is most likely due to the use of a more recent version of g++ than when 0.7 was released.

Also available in: Atom PDF