Bug report #2685

On column delete wrong aliases are shown

Added by pinux - over 10 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:GUI
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12745

Description

I have tested it only with postgis:

1. Layer Properties

2. Attributes

3. Write alieses for all the columns

4. drop a column in postgres (not the last one, but one in the middle of the table)

5. Reopen layer properties --> Attributes

6. The aliases are wrong (they are shift by 1 column)

History

#1 Updated by Volker Fröhlich almost 10 years ago

Confirmed for trunk, also happens for Shapefiles.

#2 Updated by Volker Fröhlich almost 10 years ago

A related issue:

If you drop a column from inside QGIS, the aliases should still correspond, but an additional alias gets deleted.

KONK

#3 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

duplicate of #3057.

Also available in: Atom PDF